21 agosto 2012

[resolvido] USB To Serial Prolific no Windows 7 e 8x e 10


Pessoal,

Depois de muito brigar e procurar sem sucesso uma maneira do conversor de USB para Serial PL2303 da Prolific consegui um driver que rodou sem o "Erro 10" ao inicializar o dispositivo.
Acredito ser muito útil para várias pessoas!


Edit: Testei no Windows  7 e 8 e 10 64 Bits... Funcionou 100%. O driver neste tutorial é para p Prolific "genérico", ou seja, a maioria que se vende por ai.



ATENÇÃO: Antes de fazer o procedimento, DESABILITE as atualizações automáticas do windows: Clique em http://windows.microsoft.com/pt-br/windows-vista/turn-automatic-updating-on-or-off para saber como desabilitar.

Vamos lá:
  1. Desinstale seu driver atual
  2. Baixe no novo driver para Win7/8 32 e 64 bits (Links abaixo)
  3. Desplugue seu adaptador
  4. Instale o novo driver
  5. Plugue o adaptador e espere o windows instalar.
  6. Se mesmo assim ele continuar apresentanto o ponto de exclamação no gerenciador de dispositivos, clique com o botão direito do mouse e vá em "Atualizar Driver...". Escolha buscar automaticamente o driver e deixe ele instalar. Se aparecer 2 drivers, escolha o driver versão 3.3.2.102
  7. Pronto. Seu dispositivo estará funcionando 100%
Gerenciador de dispositivos do Win7 x64 rodando o Profilic PL2303
Grande abraço!


106 comentários:

  1. Amigo Nilcemar, tentei o que vc ensinou, mas não funcionou. Portas (COM $ LPT) não aparecem no gerenciador de dispositivos. Será que pode ser isso? Como resolver?
    Grato,
    Marcos

    ResponderExcluir
    Respostas
    1. Marcos, você já tentou instalar outro driver antes desse? Porque a instalação da prolific deixa muito lixo na máquina. Faz o seguinte:
      - Desinstala o driver,
      - vai no REGEDIT e exclua qualquer referência relacionada a "Prolific",
      - vá no windows explorer, pasta arquivos de programa e exclua tudo que se refere a prolific e "PL2303"
      - Reinicie
      - Instale novamente

      Excluir
    2. Nilcemar, encontrei essa solução. Muito boa e resolveu meu problema.

      http://www.ifamilysoftware.com/news37.html

      Excluir
    3. Essa solução finalmente resolveu pra mim depois de tentar um milhão de outras, obrigado

      Excluir
  2. Olá,
    Nilcemar o link que vc postou aparece um arquivo com este nome "USBFireWire_Win7_3264.zip" e não profilic. Está correto?
    Obrigado
    Adilson

    ResponderExcluir
    Respostas
    1. Oi Adilson! Tá certo, pode baixar e instalar que vai funcionar

      Excluir
  3. não consigo e o arquivo se chama Prolific USB-to-serial Comm Port, mas não reconhece... o meu windows é 7 Starter e um AMD C-60... já tentei inúmera vezes! to desistindo já! abraço!

    ResponderExcluir
  4. acho que esse driver é para o windows vista ou me engano?

    Veja o nome do instalador: PL2303_Prolific_Vista_332102.exe

    ResponderExcluir
  5. Aleluia....muito bom. Funcionou direitinho.

    ResponderExcluir
  6. http://www.prolific.com.tw/US/supportDownload.aspx?FileType=56&FileID=133&pcid=85&Page=0

    USER : GUEST
    SENHA : GUEST

    ResponderExcluir
    Respostas
    1. Olá amigo, esse driver é para o chip original da Prolific, que não funciona na maioria dos cabos "Genéricos" vendidos por ai. Mas de todo modo muito obrigado por compartilhar

      Excluir
  7. Respostas
    1. Boa tarde Guilherme... como vc fez pra instalar no windows 8? não estou conseguindo de forma nenhuma...
      Obrigado

      Excluir
  8. poxa, pra mim continua dando erro....

    ResponderExcluir
  9. NAO CONSEGUI BAIXAR O ARQUIVO DAS LINKS QUE VOCE COLOCOU ELE DESVIA PARA UM MONTE DE COISAS MENOS PARA O ARQUIVO, POR FAVOR ME AJUDE, COMO BAIXO ESSE ARQUIVO?

    ResponderExcluir
    Respostas
    1. Amigo, baixe o arquivo em http://uploaded.net/file/forbidden/PL2303_USBSerial_Win78_3264.zip

      Excluir
  10. Link indisponível...atualize o link por favor.

    ResponderExcluir
    Respostas
    1. Amigo, utilize o link http://www.crocko.com/F5DE2E46AEC042B0A9E84ABD19083619/PL2303_USBSerial_Win78_3264.zip

      Excluir
  11. colega não consigo baixar o arquivo por esse crocko! tem como ser pelo 4shared ou por e-mail?

    ResponderExcluir
  12. MUITO OBRIGADO, DEU CERTO CONSEGUI BAIXAR E INSTALAR, FUNCIONAOU PERFEITAMENTE, AINDA BEM QUE PODEMOS CONTAR COM PESSOAS COMO VOCE, QUE DIVIDE OS CONHECIMENTOS COM OUTRAS PESSOAS.

    VALEU

    ResponderExcluir
  13. Nilcemar, desinstalei o driver da PROLIFIC, baixei o seu arquivo, instalei, mas continua o erro 10. :( Tentei atualizar o driver, como vc recomenda, mas o windows diz que o "melhor dirver j� est� instalado" � uma versao 3.4.36.247 e n�o 3.3.2.102. Uso o Windows 7 Professional 32 bits. Seria poss�vel vc me auxiliar? Preciso muito da serial....

    ResponderExcluir
    Respostas
    1. Amigo, possivelmente o windows disse ter desinstalado mas nao o fez... faz o seguinte. Reinicie em modo de segurança, vá no gerenciador de dispositivos e desinstale o driver, se ele tiver a opção de "excluir arquivos" faça-o. Reinicie em modo normal e instale o driver desse tutorial.... Aguardo retorno

      Excluir
  14. Desinstalei o driver do PROLIFIC original, desconectei o conversor e instalaei o dirver indicado por vc, mas não funcionou. tentei atualizar o driver, como vc sugere, aí ele coloca o driver 3.4.36.247 como o "mmelhor dirver par ao dispositiov". Meu Windows é 7 32bits. Agradeço desde já sua ajuda.

    ResponderExcluir
  15. http://www.crocko.com/F5DE2E46AEC042B0A9E84ABD19083619/PL2303_USBSerial_Win78_3264.zip


    Não estou conseguindo baixar por esse link.

    Pelo Driver que instalei através desse link.
    http://www.prolific.com.tw/US/ShowProduct.aspx?p_id=225&pcid=41


    Aparece a seguinte MSG: Este dispositivo não pode ser iniciado. (Código 10).

    Oque pode ser?

    ResponderExcluir
  16. Esse driver que você baixou não vai funcionar porque sua prolific nao é original, é "generico chines" assim como descrito no tutorial.
    Desinstale o driver e instale o driver do tutorial.

    ResponderExcluir
  17. Muito bom! Valeu pela ajuda...

    ResponderExcluir
  18. Este dispositivo não está a funcionar corretamente porque o Windows não consegue carregar os controladores necessários para o dispositivo. (Código 31)

    ResponderExcluir
    Respostas
    1. Possivelmente você não excluiu os drivers antigos.

      Excluir
  19. o cabo de dados é
    Type Gev189
    Art.No:734700
    Power:5V / 0,5Amax
    Manufactured:2004
    será prolema do cabo de dados

    ResponderExcluir
  20. será problema do cabo de dados que não é compatível com o Windows8

    ResponderExcluir
    Respostas
    1. Pode ser amigo, mas antes certifique-se de estar usando o driver que informei ai no post. É possivel que ainda esteja no driver antigo. Clique com o botao direito no gerenciador de dispositivos no icone Prolific e selecione "Atualizar Driver". Escolha "escolher manualmente o driver"... na lista de drivers instalados, verifique se está selecionado o driver deste post e não o original.

      Excluir
  21. a referencia do cabo é
    Type: GEV189 ART. No: 734700
    Power:5V
    MANUFACTURED:2004
    Será que é compatível ao windows8

    ResponderExcluir
  22. Demoro mas consegui!!! Obrigado

    ResponderExcluir
  23. CARA MUITO OBRIGADO ... FUNCIONOU NUMA BOA AQUI ...

    PRA QUEM MESMO DEPOIS DO TUTORIAL ESTA TENDO DIFICULDADES,
    BAIXA O DRIVER DO WINDOWS VISTA, EU NAO BAIXEI DO BLOG, BAIXEI DE 4SHARED PROCURANDO NA NET,

    QUEM QUISER ESSE É O LINK-
    http://www.4shared.com/zip/4y8gomf8/USBFireWire_Win7_3264.htm

    ABRA O GERENCIADOR DE TAREFAS, CLIQUE COM O BOTAO DIREITO EM CIMA DO DRIVER PROLIFIC (ERRO 10), DEPOIS CLICA EM DESINSTALAR E SE TIVER A OPCAO EXCLUIR DRIVERS PODE MARCAR,
    APOIS ISSO ENTRE NO REGEDIT, BUSQUE CHAVES COM O NOME PROLIFIC E EXCLUA-AS, APOS ISSO RETIRE O CABO USB, INSTALE O DRIVER BAIXADO, E VERIFIQUE, SE AINDA ESTIVER COM ERRO 10, SE ESTIVER CLIQUE COM O BOTAO DIREITO E EM SEGUIDA ATUALIZAR DRIVER, APOS ISSO CLIQUE EM BUSCAR NO COMPUTADOR, DEPOIS EM PERMITIR QUE EU ESCOLHA, APOS APARECER A LISTA DE DRIVERS, BUSQUE PELO DRIVER MAIS ANTIGO (NO MEU CASO ERA 2007).
    BATATA FUNCIONOU NORMAL NO WINDOWS 8 64 BITS.

    ESPERO TER AJUDADO...

    ABRAÇOS GALERA E OBRIGADO NILCEMAR..

    ATT.

    EVERTON MIRANDA
    ANALISTA DE SISTEMAS PL

    ResponderExcluir
  24. perfeito. o windows8 insiste em atualizar o driver mas é só reverter o driver quando for usar.obrigado

    ResponderExcluir
  25. eo intalei para atualizar pro one. fala qui ta instalado coretamente, cuando vo atualizar pro ono fala, can`t open port qui devo fazer

    ResponderExcluir
  26. Funcionou certinho amigo!!! deu um pouco + de trab. pra desinstalar o driver antigo (original) mas utilizando a ferramenta reverter driver e reiniciando deu tudo certo.Obrigado!

    ResponderExcluir
  27. Olá Nilcemar!!! Tenho windows 7 ultimate, e estou com os mesmos problemas dos colegas. Fiz todo o procedimento indicado por você, porém, não deu certo. Nem aparece no gerenciador de dispositivos a instalação do prolific. Quando pluguei o cabo depois da instalação do driver, o windows nem faz a busca.
    O que você indica fazer?

    ResponderExcluir
  28. Cara, você pode fazer 3 testes:
    1) Ver se seu cabo está funcionando em uma maquina XP
    2) Se estiver, certifique-se que todos os drivers antigos prolific estejam deletados. Faça isso no modo de segurança
    3) Reinstale com esse driver... mesmo se o driver nao for instalado o windows emite um som de dispositivo plugado.

    ResponderExcluir
  29. Funcionou aqui, valeu!

    ResponderExcluir
  30. Cara, funcionou mesmo.
    Depois de me bater um monte finalmente consegui.

    Obrigado e um grande abraço!

    ResponderExcluir
  31. Nilcemar, blz? estou a procura ja fazem uns 10 días e nada, estou com o Windows 8, 64x, e tenho um cabo, nao sei a marca que e, na verdade sou mto leigo no assunto, na ponta dele tem escrito HL-340, será que vc poderia me ajudar a encontrar o driver? pq preciso fazer um recovery em um deco, para florir, e nao consigo, Brigadao, abraco

    ResponderExcluir
  32. Pow cara funfou exatamente como você explicou aqui,
    porém a aplicação ECF que eu rodei não comunicou com a impressora, mas parabéns pela iniciativa.
    Obrigado Abraço!

    ResponderExcluir
  33. Oiii, já fiz o que vc falou, desinstalei tuuudo... ai instalei o que eu baxei no seu site, pluguei o cabo, e nada.. continua com !! amarelo.. o q posso fazer??

    ResponderExcluir
  34. Pessoal! só consegui quando desativei a isntalação automatica do windows.
    segue o tutorial no link.
    http://www.techtudo.com.br/dicas-e-tutoriais/noticia/2011/05/como-desativar-instalacao-automatica-de-drivers-no-windows-7.html

    sejam felizes!!!

    ResponderExcluir
    Respostas
    1. Sou da área de ti também, fica a dica. Fiz de tudo, limpei os drivers, instalei o do site que Nilcemar postou, instalou, mas ficava a exclamação. Depois que DESABILITEI A INSTALAÇÃO AUTOMÁTICA, fui em atualizar driver, procurar automaticamente E PRONTO. Deu certo. Obrigado LEALTKD e NILCEMAR. Vlw mesmo. Siga o site TECHTUDO para desabilitar que vai dar certo.

      Excluir
  35. Olá amigo boa tarde, como fasso p/ baixar o drivers p/ o windows-8 obrigado...

    ResponderExcluir
    Respostas
    1. Amigo, esse driver serve no Windows 8. Eu o uso no Win8 x64 com sucesso!

      Excluir
    2. BOA NOITE! ESTOU COM ESSE PROBLEMA TAMBEM, NAO ENCONTREI NADA QUE RESOLVESSE ESSE ERRO, O DRIVE NAO INSTALA, USO W7 64BITS.
      AGRADEÇO MUITO SE PUDER ME AJUDAR.

      Excluir
    3. amigo, a ajuda esta ai.. só seguir os passos que dara certo!

      Excluir
  36. Vlw ai nilcemar, problema resolvido após excluir registro... abraço

    ResponderExcluir
  37. Como é bom contar com pessoas de boa intenção para ajudar obrigado a todos por aqui!

    ResponderExcluir
  38. deu certo.
    segui todos os passos, só que na hora que pluguei o cabo eu canselei a instalação pelo windows update, então não foi atualizado o driver ficando o driver que instalei baixado do link deste blog.
    antes de consseguir eu deixava o windows update instalar o driver e sempre atualizava para o driver 3.4.36.247, mesmo depois de excluir todos os registros antigos do driver, ocorrendo o erro 10.
    valeu Nilcemar.agora sim posso me concentrar de fato nos meus projetos.

    ResponderExcluir
    Respostas
    1. Fico contente por ajudar!!! Precisando estamos ai! Grande abraço

      Excluir
  39. Boa tarde, no meu caso só funcionou com o seu Driver, e também desativando a procura de drivers no Windows Update, dessa forma ele iniciou o dispositivo pelo driver do pc, e não ficou procurando no WU.

    ResponderExcluir
  40. Nilcemar,

    não estou conseguindo.
    Uso Vista Home Premium.
    Limpei o registro e deletei todos files com os nomes 2303 ou Prolific.
    Alguma dica?

    ResponderExcluir
  41. demaaisss!!! vlw cara!!! win 7 64b funcionando! =D

    ResponderExcluir
  42. Olá, boa noite!

    Poderia me ajudar a resolver o problema do erro cod. 10 ( dispositivo não inicializado )?
    estou com um cabo da LeaderShip Win8 x64Bits mais não vai..

    alguma dica, fico no aguardo!

    ResponderExcluir
    Respostas
    1. Amigo, esse cabo leadership possivelmente usa um chipset da prolific. Verifique no gerenciador de dispositivos o nome que ele é identificado. Depois desconecte da internet e desinstale o driver e instale esse arquivo aqui do post. Se for prolific 2303 vai funcionar.

      Excluir
  43. Opa tudo bem cara? Seguinte durante todas funções que estava passando aqui para tentar fazer funcionar meu leadership acabei chegando a uma tela azul, que quando plugo o cabo aparece, falando sobre um erro WDF_Violation e reinicia. Agora não consigo mais nem plugar o cabo para tentar fazer o driver funcionar =/ Win 8 64bit

    Qualquer ajuda vem bem pq já estou um pouco mais calvo...

    Valeu pela atenção! Abraço !

    ResponderExcluir
    Respostas
    1. OBS: Restaurei o sistema pra data anterior que eu pluguei o cabo pela primeira vez. Mesmo assim quando instalo o .exe do driver (desligado da net e desativei a atualização automatica do windows) ele volta novamente a dar problema e tenho que restaurar o sistema...

      Excluir
    2. Reinicia em modo de segurança e desinstale o driver... Nesse caso recomendo entrar em contato com o Fabricante mesmo!

      Excluir
    3. Pois é cara eu restaurei o sistema pra manha do dia que comprei o cabo (sorte). Posso conectar novamente ele. Mas cada vez que instalo o driver e conecto o cabo volta a dar o mesmo problema...

      Excluir
  44. Oii gente, estou tentando instalar este cabo usb/serial, ja fiz todos os passos descritos por voces mas mesmo assim nao consigo resolver... tenho o cabo da integris, meu pc eh w7 32... aparece sempre o erro 31. Quando mando atualizar o driver, aparece a mensagem de erro "este dispositivo nao esta funcionando corretamente porque o windows nao pode carregar os drivers necessarios para este dispositivo"...

    Heeeelp! kkkkkkkk preciso fazer um trabalho pra facul com microcontroladores e preciso desse cabo instalado pra conseguir gravar no micro...

    ResponderExcluir
  45. Boa noite

    estou ficando louco, não consigo instalar de jeito nenhum, eu tinha instalado normalmente mas nao sei por qual motivo não esta mais reconhecendo, preciso que tenha comunicação usb para serial com o lacrador da sweda 1.01.
    tentei todas as portas e todas as velocidades e nada.

    ResponderExcluir
    Respostas
    1. Amigo, desabilite a atualização do driver pelo windows update ou desconecte seu computador da internet antes de instalar o driver. Remova o driver e os arquivos e reinstale. Se não der o jeito é comprar outro cabo ou testá-lo instalando em outro computador.

      Excluir
    2. É possivel que seu cabo não seja prolific

      Excluir
    3. fala que o software não foi instalado com exito

      Excluir
  46. Agora está falando que esta instalado na COM15 mas eu não tenho essa saida 15, e no lacrador só vai até a saida 9, e já tentei em todas e nada

    ResponderExcluir
    Respostas
    1. Amigo, aí é simples... vai nas propriedades do adaptador (dentro do gerenciador de dispositivos) e altere a porta COM para uma menor que COM9 e reinicie que vai funcionar

      Excluir
  47. não consigo alterar, ele nao me da opçoes para alterar.

    ResponderExcluir
  48. o problema agora é que não sei qual o numero dessa porta usb que eu instalei, ja tentei em todas e nenhuma responde. só aparece que esta instalado eu consigo trocar as portas, mas não sei o numero da que eu instalei, só aparece que esta instalado na portas com e lpt, preciso de um jeito de saber qual o numero dessa merda de porta usb, só tem 3 no meu pc, é um ACER 57506697 WINDOWS 7 HOME BASIC, pode me ajudar??

    ResponderExcluir
  49. Muiiiiiiiiiiiitooooooooooooo Obrigado.

    Funcionou 100%, estou usando no Windows 7 ultimate 32bits.

    e meu adaptador é genérico, descobri pq no conector rs-232 está escrito 2303.

    Abraço.

    ResponderExcluir
    Respostas
    1. Rodrigo.

      Muito obrigado! Eu estava com este problema de camunicação a uma semana e as dicas da galera principalmente do Nilcemar Ferreira e do colega
      Everton Miranda. Mais uma vez obrigado pela força.

      Excluir
  50. shoooooow... funcionando 100% apenas com as dica iniciais.. baixei do google drive dele. meu windows 8 x64. cabo gev189

    ResponderExcluir
  51. estou com msm problema no win 7 starter...

    sera q esse procedimento resolve???

    obrigado

    ResponderExcluir
  52. Show de bola, tava me batendo e agora funcionou perfeitamente. Valeu.

    ResponderExcluir
  53. A INSTALAÇÃO DEU CERTO, NAO ACUSA ERRO NO GERENCIADOR DE DISPOSITIVO, MA SNA HORA DE DISCAR DÁ ERRO, USONO CELULAR AQUARIO, E NA AQUARIO NAO ME DERAM SOLUÇÃO

    ResponderExcluir
    Respostas
    1. Amigo, verifique se a porta do cabo é a mesma configurada no programa ou no equipamento. Possivelmente não é. Verifique.

      Excluir
    2. Brother! Funcionou perfeitamente! Tava achando que estava com problema o adaptador! Muito Obrigado!

      Excluir
  54. Muito bom! Valeu obrigado!

    ResponderExcluir
  55. Tudo que eu precisava, funcionou perfeitamente!!

    Obrigado

    ResponderExcluir
  56. senhores, alguem pode me ajudar? fiz todos os procedimentos acima porém acontece comigo o seguinte: o adaptador serial/usb da prolific que tenho quando liga a meu equipamento simplesmente não o reconhece. o equipamento que possuo em si é um site master da anritsu( modelo S331D ). no gerenciador de dispositivos está tudo correto: driver instalado na porta COM sem problemas. o negócio é que simplesmente quando conecto o cabo no equipamento não lê, não acusa nada que o equipamento está acoplado. Alguém pode me ajudar? Abraços. Marcel.

    ResponderExcluir
    Respostas
    1. Amigo, normalmente equipamentos seriais não são plug and play. Na maioria dos casos vc precisa de um programa do equipamento que comunica via serial. Se tiver o programa instalado, verifique se a COM do programa é a mesma COM estabelecida no adaptador.

      Excluir
  57. Nilcemar, eu atualizei o meu XP para o Windows 10 e fiquei sem meu adaptador usb_serial. Esse arquivo que vc falou, serve para esse Sistema Operacional? meu windows é 32 bits

    ResponderExcluir
  58. Nilcemar, obrigado! Solucionou meu problema! Excelente!

    ResponderExcluir
  59. Parabens funcionou direitinho . Excelente

    ResponderExcluir
  60. Parabéns e muito obrigado Nilcemar.
    Funcionou de primeira!!!
    Gerson

    ResponderExcluir
  61. Valeu, cara! Você me salvou! Só um comentário: não instalou automaticamente e eu tive que optar por procurar em meu computador e depois optar por drivers que "já existiam" em "meu computador" e a tua versão apareceu lá... Grato.

    ResponderExcluir
  62. Valeu pela dica. Funcionou corretamente Windows 8.

    ResponderExcluir
  63. parabens voce eh muito bom fazia dias que estava tentando instalar essa bomba kkk valeu

    ResponderExcluir
  64. Depois de muito quebrar a cabeça, acabei desistindo desses adaptadores com chip da Prolific. Hoje precisei e resolvi procurar e achei seu valioso post. Salvei 3 adaptadores que já estavam abandonados. Obrigado e grande abraço.

    ResponderExcluir
  65. Funcionou! Windows 10 - 64Bits.
    Valeu!!

    ResponderExcluir
  66. Funcionou perfeito em Windows 10.
    Valeu Nilcemar!!!
    Obrigado!!

    ResponderExcluir
  67. Pls favor, algém poderia passar um link que ativo, todos os citados não contém este arquivo mais.

    ResponderExcluir
  68. É verdade, Flávio. O primeiro, o do Google Drive, diz que não é possivel acessar o item ,pois viola os termos etc etc.
    O de baixo, o alternativo, fica direcionando a um outro site que,me parece,temos que cadastrar para poder baixar. O meu USB Serial é Prolific, tem um nr. 2303 , e, na embalagem da Leadership esta escrito " Made in China",ou seja, deve ser o genérico. Tinha baixado um outro driver na net,versão 3.8 e alguma coisa, e tava dando erro.Deve ser o do chip original,por isso o tal erro. Isso é o que eu imagino,né !!!! Abs/ Ozanan-JF

    ResponderExcluir
  69. Olá... atualizei o link para download no Mega..

    ResponderExcluir
    Respostas
    1. Boa noite,Nilcemar. Pelo novo link, o do Mega,foi BINGO na hora. Instalou sem problemas e SEM " Exclamação Amarela".Na verdade, eu já tinha esse PL 2303 instalado,quando era XP e,lembro-me bem que,na época, tive que tirar a " exclamação amarela" na "pancada" (rsrsr).Mesmo instalado,nunca consegui fazer recover em receptores.Mudei recentemente pra Win 7 e tava difícil de instalar o conversor.Nem no site da Leadership ,por onde eu peguei pela primeira vez,encontrava os drivers.Esse foi sem erro. Vale ressaltar que,ontem, eu andei desativando a instalação automática de drivers,dica que alguém
      postou aqui mesmo,nos comentários.Isso pode ter ajudado. Vabs. Ozanan/JF

      Excluir